ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: can't get optional scp to work - ant 1.6.2
Date Mon, 21 Nov 2005 20:21:40 GMT
Eric Wulff wrote:

>Hi, I'm trying to run the optional scp task (ant 1.6.2 - java 1.4.2)
>but it's complaining.  I feel I've covered the most likely problems
>and now I'm running around with my head cut off  :).
>
>- my usr/local/ant is in my path
>- I have verified the jsch.jar dependency in my ant.home/lib (I've
>tried adding it to my classpath as well, which seems redundant, but
>this didn't help)
>- I have verified that there is more than just a manifest in the .jar
>
>I ran diagnostics and got the following missing dependency...
>
>scp : Missing dependency com.jcraft.jsch.UserInfo
>
>Does that mean ant isn't seeing the jsch.jar at all or that the .jar
>is missing something?
>
>  
>
Hello Eric,
this would rather mean that ant is not seein the jsch.jar. My copy of
jsch.jar has this class. It is :
jsch-0.1.15.jar - which does not mean that more recent versions of jsch
do not work.
Check also whether you have ant-jsch.jar and whether it is not a
manifest only file.
Sometimes users complain about "home-made" builds of ant where the
various optional jars are
manifest only due to the absence of the ant dependencies at build tim.

Cheers,

Antoine

>Eric
>
>
>ant output...
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message