ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: running tests for ant 1.6.4
Date Tue, 15 Nov 2005 22:34:50 GMT
Manish Marathe wrote:

>
> I followed the exact steps as you suggested. I am attaching stack
> trace of the tests which have failed. Some have failed because of
> missing .NET apps. I don't know what that means..
>
> Let me know your suggestion.
>
Hello Manish,

in the CVS HEAD version the DOT NET are prevented from running by
default in the category "TestsThatFail".
in Ant 1.6.4 the DOTNET tests run by default, without checking whether
the dotnet tools are in the path. Strange.

Concerning ClasspathUtilsTest [2],

Peter Reilly wrote in the changelog of ClassPathUtilsTest.java :

with the bugzilla change 30161 [3] it is not necessary to place
 Path.systemClasspath in the antclassloader
Doing so causes resources to appear twice

I do not know the cause of what is happening there with ClassPathUtils.
It looks like you do have the same resource available twice.

I wonder whether I did not do this before running my tests :

rm $ANT_HOME/lib/ant*jar

like that :

set ANT_HOME=whereever I want ant installed
rm -rf bootstrap
rm $ANT_HOME/lib/ant*jar
./build.sh -D"test.haltonfailure=false" install-lite test



Cheers,

Antoine

[1]
http://cvs.apache.org/viewcvs.cgi/ant/build.xml?rev=1.392.2.44&view=markup
[2]
http://cvs.apache.org/viewcvs.cgi/ant/src/testcases/org/apache/tools/ant/util/ClasspathUtilsTest.java?rev=1.1&view=log
[3] http://issues.apache.org/bugzilla/show_bug.cgi?id=30161

excerpt from your build log

------------------------------------------------------------------------

    [junit] Testcase: testOnlyOneInstance(org.apache.tools.ant.util.ClasspathUtilsTest): 
      FAILED
    [junit] Should be only one and not 2  jar:file:/home/oss/.ant/lib/ant.jar!/org/apache/tools/ant/taskdefs/defaults.properties
jar:file:/opt/cm-cvsroot/latest/comps/ant/src/bootstrap/lib/ant.jar!/org/apache/tools/ant/taskdefs/defaults.properties
    [junit] junit.framework.AssertionFailedError: Should be only one and not 2  jar:file:/home/oss/.ant/lib/ant.jar!/org/apache/tools/ant/taskdefs/defaults.properties
jar:file:/opt/cm-cvsroot/latest/comps/ant/src/bootstrap/lib/ant.jar!/org/apache/tools/ant/taskdefs/defaults.properties
    [junit]     at junit.framework.Assert.fail(Assert.java:47)
    [junit]     at junit.framework.Assert.assertTrue(Assert.java:20)
    [junit]     at org.apache.tools.ant.util.ClasspathUtilsTest.testOnlyOneInstance(ClasspathUtilsTest.java:64)



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message