ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert r. Sanders" <robert.sand...@ipov.net>
Subject Re: XSLT Param from ANT Property.
Date Tue, 08 Nov 2005 22:22:09 GMT
Ok, I think the issue was that I had fixed my ANT file (which had been 
setting the param incorrectly) but there was some kind of up-to-date 
check, and since neither the source XML nor the XSLT files had changed 
the output xml wasn't getting regenerated.

Dominique Devienne wrote:
>> I'm using the XSLT task from within ANT; and can't seem to get the
>> <param ... /> parameter to work as it seems it should.
>>
>> When I open the output xml; the params have been set to the strings
>> "props.prop1" and "props.prop2" instead of the runtime values.  Am I
>> doing something wrong?  Any help would be very useful.
>>     
>
> This works fine for me (using properties in expression. see below for
> an example). Try doing an echo of the properties before <xslt>, as in
>
> <echo>props.prop1 = ${props.prop1}</echo>
>
> --DD
>
>     <style in="${javadocs}/index2.xml" out="${javadocs}/index.html"
>            style="config/javadocs-index.xsl">
>       <param name="cycletitle" expression="${cycletitle}" />
>     </style>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>   

-- 
    Robert r. Sanders
    Chief Technologist
    iPOV
    (334) 821-5412
    www.ipov.net


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message