ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <ddevie...@gmail.com>
Subject Re: <exec> and '$' symbol on Solaris 8
Date Tue, 22 Nov 2005 14:27:49 GMT
> FIXED!!! The point is the environment variable LANG.
>
> ProductIndexer connects to Oracle DB during its work. For right work of
> oracle database connection it is necessary to indicate language. New
> property shall be added:
>        <property name="LANG" value="en_US.ISO8859-1"/>
>        <exec ... >
>            <env key="LANG" value="${LANG}"/>
>        </exec>

Hmmm, AFAIK a child process inherits its parent process environment,
so if you were able to run the command in a shell OK, it implies that
LANG was defined correctly, so running Ant from the same shell should
also have worked, no?

You could test this by <exec>ing the env command and see if the LANG
var set on the parent shell (or not) is listed in the output of the
<exec>'d env (or not).

It's good that you fixed it, but this is puzzling nonetheless ;-) --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message