ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Currimbhoy Shahyan <shahyan.currimb...@siemens.com>
Subject Exec task does not fail inspite of non-zero error level
Date Fri, 05 Aug 2005 18:03:15 GMT

Hi,
 
I am using an ant script to trigger off my builds and unit tests but for
some reason I am unable to get the exec task to work properly.
My ant script contains the following code snippet:
<!-- Build component -->

<target name="build" depends="init">

<exec executable="${root}/BUILDLOCAL.CMD" failonerror="true"

output="${output.dir}/build.txt">

</exec>

</target>

 

All my BUILDLOCAL.CMD does is set ERRORLEVEL=50.

This should cause my build task to fail however for some reason my build
executes successfully.

Could you tell me what I am doing wrong. I was under the impression that
failonerror=true should cause a failure if errorlevel is non-zero.

 

Thanks in advance,

Shahyan.

 



-------------------------------------------------------------------------------
This message and any included attachments are from Siemens Medical Solutions 
USA, Inc. and are intended only for the addressee(s).  
The information contained herein may include trade secrets or privileged or 
otherwise confidential information.  Unauthorized review, forwarding, printing, 
copying, distributing, or using such information is strictly prohibited and may 
be unlawful.  If you received this message in error, or have reason to believe 
you are not authorized to receive it, please promptly delete this message and 
notify the sender by e-mail with a copy to Central.SecurityOffice@shs.siemens.com 

Thank you
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message