ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Maclean <stu...@apl.washington.edu>
Subject ant shell wrapper surprise, try to run version A, runs version B
Date Fri, 26 Aug 2005 20:12:36 GMT
OS is Linux.  ANT_HOME is set to /path/to/ant-1.6.5.

Now, I want to run an older version of Ant for some reason, so I fully 
qualify the script at the shell cmd line

% /path/to/ant-1.6.2/bin/ant

and it STILL runs 1.6.5.  Grrrrrrrrrrrr.  The ant script (for 1.6.2 
anyways, and 1.6.5 looks the same to me) checks FIRST to see if ANT_HOME 
is defined, and if it is, go with it.  Shouldn't it FIRST check $0 to 
see if it could derive an ANT_HOME from that, using eg dirname.  grrrr

Stu



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message