ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Vervelle <>
Subject Re: scp problem: received directory without -r [SOLVED]
Date Tue, 02 Aug 2005 06:18:41 GMT

Anderson, Rob (Global Trade) wrote:

>The SSH Server version looks OK. Perhaps there is a directory in your fileset where previously
there were only files. Using a zip file is probably the best solution.
With no answer from sourceforge support team (holidays ...), I used the 
zip solution.
It's working fine now, thanks for the help.
I still don't know why it's not working anymore with direct scp but I 
will now work with tar + gzip + scp :)


>-Rob A
>>-----Original Message-----
>>From: Nicolas Vervelle []
>>Sent: Friday, July 29, 2005 12:02 AM
>>To: Ant Users List
>>Subject: Re: scp problem: received directory without -r
>>Anderson, Rob (Global Trade) wrote:
>>>What version of SSH server is on the remote end ? I seem to 
>>remember this error from something, but I don't think I saw 
>>it using the scp Ant task. It looks like the fileset may be 
>>sending directories, and not just files. I would suggest 
>>creating a zip or tar.gz with the fileset first. Then scp to 
>>remote, and use sshexec to unpack the archive on the remote side. 
>>When I log onto server, I tried getting the 
>>version with 
>>'ssh -V'
>>Result: OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, Open SSL 0x00090701f
>>Can it be the problem ?
>>What's strange is that the task was working perfectly before 
>>(I used it 
>>for several months).
>>One other think I have to check is when I updated Eclipse 
>>from 3.0.1 to 
>>I thought I was still using 3.0.1 but apparently I am with 3.0.2 now.
>>I will try the zip idea if I don't get an other answer from 
>>support :)
>>Thanks for the answer.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message