ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Kuhn <bnk...@gmail.com>
Subject Fwd: SCP...done...BUILD SUCCESSFUL....no local file created
Date Mon, 08 Aug 2005 16:17:14 GMT
Has anyone gotten the SCP task to work correctly?  I need to copy a
single file from a server to my local machine using SSH.  Does anyone
have a working example?

Thanks,
     Brian



---------- Forwarded message ----------
From: Brian Kuhn <bnkuhn@gmail.com>
Date: Aug 4, 2005 5:34 PM
Subject: SCP...done...BUILD SUCCESSFUL....no local file created
To: Ant Users List <user@ant.apache.org>


Hi all,

I'm using the following snippet to SCP a file from a remote machine to
my local machine.  The output looks fine (although I can't get it to
be more verbose, no matter what I try).  However, I don't get a local
copy of the file even though it says "done" and BUILD SUCCESSFUL.  Any
ideas.  I saw a couple dead threads that related to this so I assume
someone else has at least had the same problem.  I'm using Ant 1.6.5
and Jsch 0.1.20.  The local machine is Win2k and the remote is Solaris
9 I think.

Thanks,
     Brian


My Snippet:
<scp file="${username}:${password}@${server}:${remoteDir}/${filename}"
         todir="${basedir}" trust="true" verbose="true" failonerror="true" />


My Output:
[scp] Connecting to accs3:22
[scp] Receiving file: /home/infr/050804_MASTER_DDL_AND_DATA.sql
[scp] done

BUILD SUCCESSFUL
Total time: 5 seconds

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message