ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ninju Bohra <ninju_bo...@yahoo.com>
Subject Is should be simple...but
Date Thu, 18 Aug 2005 17:17:04 GMT
Hello all,

We are (finally !!!) starting to look at Java 1.5 at
our project site.  And the first step is to build our
code using the 1.5 JDK but in 1.4 compliant mode.

After installing jdk1.5.0_04, I modified my <javac> to
the following:

        <javac 
               destdir="${classes.dir}"
               includes="**/*.java"
               memoryMaximumSize="512m"
               debug="true"
               compiler="javac1.4"
               target="1.4"
               fork="true" 
               deprecation="false">
            .
            .
        </javac>

Note, the compiler and target attributes.

When I run it I get the follow error:

cybere_compile:
    [javac] Since fork is true, ignoring compiler
setting.
    [javac] Compiling 1605 source files to
C:\Projects\classes
    [javac] Since fork is true, ignoring compiler
setting.
    [javac] javac: target release 1.4 conflicts with
default source release 1.5

What's up with that?

How do I get 1.4 bytecode emitting using the <javac>
task with jdk1.5.0_04

Thanx,

Ninju





		
__________________________________ 
Yahoo! Mail 
Stay connected, organized, and protected. Take the tour: 
http://tour.mail.yahoo.com/mailtour.html 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message