ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KrustyDerClown" <KrustyDerCl...@gmx.de>
Subject cvs task with cvs log command
Date Fri, 05 Aug 2005 10:05:38 GMT
Hello,

i have a problem with the <cvs> task in ANT. Here my cvs target:

<cvs cvsRoot="${cvs.root}" quiet="true"
command="log -d &quot;2005-08-01&lt;2005-08-03&quot; 
C:/wsad/workspace/deployment_utilities &gt; c:\\new_test.log" 
failonerror="yes" >
</cvs>

But i get this error:

[cvs] cvs log: cannot open CVS/Entries for reading: No such file or 
directory
[cvs] cvs [log aborted]: no repository
[cvs] retCode=1

And this infos:

Execute:Java13CommandLauncher: Executing 'cvs' with arguments:
'-d:pserver:ROOT(changed for security reasons)'
'-q'
'log'
'-d'
'2005-08-01<2005-08-03'
'C:/wsad/workspace/deployment_utilities'
'>'
'c:\\new_test.log'

The problem is that ANT dont pass the " around the 2 dates with the CVS 
command.

Why ?

This following cvs command works (tested without ANT, directly with CVS):

cvs -d:ROOT(changed for security reasons) -q log -d "2005-08-01<2005-08-03" 
C:/wsad/workspace/deployment_utilities > c:\\new_test.log

Have anyone an idea ? How can i pass the " to the CVS command ?

Any workaround for me ?

Thank you for your help.

Greets Oliver




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message