ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ninju Bohra <ninju_bo...@yahoo.com>
Subject Re: AntServer and RemoteAnt problems
Date Fri, 01 Jul 2005 19:23:21 GMT
If I read the build files correctly the problem is
that your Windows XP build file is trying to execute a
task on the remote ANT (on the linux) that does not
exist.

The WinXP target named =
"exec.task.on.remote.ant.server" is trying to run the
target named = "task.on.remote.machine" but I don't
see such named target in the Linux build file.

You have a target with name on the WinXP build file
but it needs to be in th remote build file (or in a
build file that reachable from the remote build file)
Ninju

--- Chad Armstrong <chad.armstrong@gmail.com> wrote:

> Hello,
>   I'm having problems getting AntServer and
> RemoteAnt to run
> successfully. The gist is that I have a build file
> running on an XP
> box that should kick off a build file on a linux
> box. Here is what I
> have done so far (just to test the communication
> between the
> machines):
> 
> 
> ON LINUX BOX:
> -copied ant-contrib.jar to
> /usr/local/apache-ant-1.6.2/lib
> -created remote.xml
> ------------------------------
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <project name="RMI" basedir="."
> default="start.ant.server">
> 	<path id="classpath">
>                 <fileset
> dir="/usr/local/apache-ant-1.6.2/lib">
>                         <include name="**/*.*jar"/>
>                 </fileset>
>         </path>
>         <target name="start.ant.server">
>                 <taskdef
> resource="net/sf/antcontrib/antcontrib.properties">
>                         <classpath
> refid="classpath"/>
>                 </taskdef>
>                 <antserver port="12345" />
>         </target>
>         <target name="remoteant">
> 		<ant target="" antfile="build.xml" />
>         </target>
> </project>
> ------------------------------
> -ran the following on the linux box: ant -f
> remote.xml
> -this starts about 10 java processes and no errors
> 
> ON XP BOX:
> -copied ant-contrib.jar to C:\ant\lib
> -created RMI.xml
> -------------------------------
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <project name="RMI"
> default="exec.task.on.remote.ant.server">
>         <path id="classpath">
>                 <fileset dir="C:\ant\lib">
>                         <include name="**/*.*jar"/>
>                 </fileset>
>         </path>
>         <taskdef
> resource="net/sf/antcontrib/antcontrib.properties">
>                 <classpath refid="classpath"/>  
>         </taskdef>
>         <target
> name="exec.task.on.remote.ant.server">
>                 <remoteant machine="10.11.12.15"
> port="12345">
>                         <runtarget
> target="task.on.remote.machine" />
>                 </remoteant>
>         </target>
>         <target name="task.on.remote.machine">
>                 <echo message="hi"/>
>         </target>
> </project>
> -------------------------------
> -verified that remote IP is 10.11.12.15
> -ran the following: ant -f RMI.xml
> -produces output:
> 
> >>>>>>
> Buildfile: RMI.xml
> exec.task.on.remote.ant.server:
> [remoteant] Command caused a build
>
failure:net.sf.antcontrib.antserver.commands.RunTargetCommand@9cb0f4
> C:\RMI.xml:12: One or more commands failed.
> Total time: 1 second
> BUILD FAILED
> >>>>>>
> 
> thanks for any help
> Chad
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
> user-help@ant.apache.org
> 
> 






		
____________________________________________________ 
Yahoo! Sports 
Rekindle the Rivalries. Sign up for Fantasy Football 
http://football.fantasysports.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message