ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KrustyDerClown" <KrustyDerCl...@gmx.de>
Subject Re: Fileset in Copy Task
Date Mon, 11 Jul 2005 13:00:42 GMT
Hello,

i am sorry. I am stupid. :)

I have another include: <include name="**/com/**/*.* />

So .. what happens ... in the WEB-INF dir there is anywhere a /com dir .. 
and this are copied. So thats why the task copied a part of the /WEB-INF dir 
to C:/temp.

I see it when i start with -debug. Thanks for the help.

----- Original Message ----- 
From: "Conor MacNeill" <conor@apache.org>
To: "Ant Users List" <user@ant.apache.org>
Sent: Monday, July 11, 2005 2:37 PM
Subject: Re: Fileset in Copy Task


> KrustyDerClown wrote:
>> Hello,
>>
>> i have a little problem with my copy task in ANT.
>>
>> I have the following target:
>>
>> <copy todir="C:/temp">
>>     <fileset dir="C:/workspace">
>>         <include name="*.*" />
>>         <include name="gifs/*.*"/>
>>         <exclude name="**/*.jsp"/>
>>     </fileset>
>> </copy>
>>
>> So ... thats works ... BUT ... the task copied the WEB-INF dir from 
>> C:/workspace also to C:/temp.
>>
>> I am really confused why .. :) All other dir's in C:/workspace like "lib" 
>> or "test" are NOT copied .. why copied my task the WEB-INF dir ?
>>
>> Thank you in advance for your reply.
>>
>
> Have you run Ant in debug mode - it may give you a clue? Also in the
> copied WEB-INF, are there any files in the dir and if so, whart are they?
>
> Conor
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message