ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Philimonov" <alexey.philimo...@db.com>
Subject Java 1.3.1_11 + Ant 1.6.4 = filter problems
Date Thu, 02 Jun 2005 10:20:29 GMT
Hi all,

I'm using Java 1.3.1_11 (yes I know it's old but can do nothing with this) 
and got a problem with filters while trying to migrate from Ant 1.5.4 to 
1.6.4.

This worked fine with Ant 1.5.4, but does nothing with 1.6.4:

<filter filtersfile="${ENV_DIR}/some.properties"/>
<copy file="config/SetEnv.tok" tofile="${TMP_DIR}/config/SetEnv" 
filtering="true">
</copy>

This works just fine with 1.6.4 with absolutely the same files:

<copy file="config/SetEnv.tok" tofile="${TMP_DIR}/config/SetEnv">
<filterset>
<filtersfile file="${ENV_DIR}/some.properties"/>
</filterset>
</copy>

I can't figure out what's wrong in the first case - neither -verbose nor 
-debug didn't give me a clue why filtering doesn't happen. I tried to 
reproduce this problem in the test build file - unsuccessfully. My real 
build files are very complex and deeply nested, maybe this might cause the 
problem.

Unfortunately, I can't just rewrite everything like in the second example 
since I must be backward-compatible (and because there's huge amount of 
this stuff).

Any ideas?


best regards,
Alexey Philimonov


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message