ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rich Harris" <rhar...@shopping.com>
Subject RE: Sshexec task, running commands using 'sudo'
Date Tue, 14 Jun 2005 23:39:36 GMT
An addendum...I noticed that when running 'sudo' commands manually I get
prompted for my password the first time I use it. That may be where it's
hanging. The uname/pass auth. only happens upon the initial ssh connect
using the sshexec and doesn't carry over through the session if you need
to run sudo. I would assume that since 'sudo' may be something widely
used for administrative purposes there may be solution or fix for
this....at least I hope so. :-)

Any help is appreciated.
-Rich


_____________________________________
Rich Harris
Release/Configuration Engineer
rharris@Shopping.com
650-616-6866 
 
Shopping.com(tm), Inc.
Find. Compare. Buy.
www.shopping.com


-----Original Message-----
From: Rich Harris [mailto:rharris@shopping.com] 
Sent: Tuesday, June 14, 2005 4:28 PM
To: Ant Users List
Subject: Sshexec task, running commands using 'sudo'

I'm having an issue where if I need to run 'sudo' before running a
command during my ssh session, it just hangs ant until I escape out of
ANT. Has anyone else had this problem? I'm open to ideas as to why this
is happening or how I can get around it while staying within the ANT
environment.

Thanks,
Rich

_____________________________________
Rich Harris
Release/Configuration Engineer
rharris@Shopping.com
650-616-6866 
 
Shopping.com(tm), Inc.
Find. Compare. Buy.
www.shopping.com <http://www.shopping.com/> 





---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message