ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S I" <xia...@hotmail.com>
Subject RE: sshexec
Date Wed, 15 Jun 2005 22:53:31 GMT
I think it's missing the attribute trust="yes"

Try it and see if it works.

----Original Message Follows----
From: luke@chipcity.com.au
Reply-To: "Ant Users List" <user@ant.apache.org>
To: user@ant.apache.org
Subject: sshexec
Date: Thu, 16 Jun 2005 07:45:57 +0930
MIME-Version: 1.0
Received: from mail.apache.org ([209.237.227.199]) by mc3-f37.hotmail.com 
with Microsoft SMTPSVC(6.0.3790.211); Wed, 15 Jun 2005 15:16:39 -0700
Received: (qmail 65550 invoked by uid 500); 15 Jun 2005 22:16:32 -0000
Received: (qmail 65531 invoked by uid 99); 15 Jun 2005 22:16:32 -0000
Received: pass (hermes.apache.org: local policy)
Received: from spider.comstech.com.au (HELO spider.comstech.com.au) 
(202.6.138.245)  by apache.org (qpsmtpd/0.28) with ESMTP; Wed, 15 Jun 2005 
15:16:31 -0700
Received: from localhost 
(dialup-116.56.221.203.acc06-waym-adl.comindico.com.au [203.221.56.116])by 
spider.comstech.com.au (Postfix) with ESMTP id 467544A74Cfor 
<user@ant.apache.org>; Thu, 16 Jun 2005 07:45:58 +0930 (CST)
X-Message-Info: JGTYoYF78jHehJiACVZC+bGidoWD4bRBRg4dFlYy8pU=
Mailing-List: contact user-help@ant.apache.org; run by ezmlm
Precedence: bulk
List-Unsubscribe: <mailto:user-unsubscribe@ant.apache.org>
List-Help: <mailto:user-help@ant.apache.org>
List-Post: <mailto:user@ant.apache.org>
List-Id: "Ant Users List" <user.ant.apache.org>
Delivered-To: mailing list user@ant.apache.org
X-ASF-Spam-Status: No, hits=0.8 required=10.0tests=HOT_NASTY,NO_REAL_NAME
X-Spam-Check-By: apache.org
User-Agent: Mutt/1.4.1i
X-Virus-Checked: Checked
Return-Path: user-return-50680-xiamak=hotmail.com@ant.apache.org
X-OriginalArrivalTime: 15 Jun 2005 22:16:40.0156 (UTC) 
FILETIME=[E74FE1C0:01C571F7]

Hi,

I saw some posts on sshexec and decided to try and use it.
I put the jsch-0.1.20.jar in the ANT_HOME/lib directory, but can't get a
build.xml file to carry out the task.


<?xml version="1.0" encoding="UTF-8"?>
<project>
  <sshexec host="203.xxx.xxx.xxx" username="joe" password="bloggs" 
command="cd
/home/joe; ls -al"/>
</project>

I get:
/home/joe/build.xml:11: Could not create task or type of type: sshexec.

what am I doing wrong?

Any help appreciated,

kind regards,
Luke

--
............._..
.|  .| |.|/.|_ .
.|__.|_|.|\.|_ .
:61 421 276 282:

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message