ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pollähne. Ullrich <U.Pollae...@seeburger.de>
Subject Performance difference between 1.6.1 and 1.6.4 (in eclipse)
Date Thu, 16 Jun 2005 07:48:24 GMT
Hi,

most of the time I use ANT from within eclipse.
With eclipse 3.1M6 there is ANT 1.6.1 and eclipse 3.1RC2 comes with ANT 1.6.4.
I am running this stuff on Windows XP Pro with SP2 on a P4 3 GHz (1024MB RAM).

There are some non-trivial scripts that I run every day.
One of them (referenced as script1) is fetching a lot of files with the get task over https.
The other one (referenced as script2) is deleting/copying/unzipping files from the eclipse
workspace to another location and is doing this with a lot of <ant> calls since there
are several sub-scripts in several subdirectories.

For comparison I created small bat files to run ANT from commandline.

For script1 I get the following numbers:
ANT 1.6.1	=> 11 sec
ANT 1.6.4	=> 32 sec

For script2 I get the following numbers:
ANT 1.6.1	=> 34 sec
ANT 1.6.4	=> 1 min 16 sec

Can some one explain this difference?

The difference to be seen on the screen is that ANT 1.6.1 prints line by line whereas 1.6.4
prints in chunks of 3 or 4 lines (which makes the output a bit jumpy).

Ullrich.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message