ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Danja Spoja <d.bel...@xpedite.com>
Subject wsdltodotnet task
Date Thu, 23 Jun 2005 14:45:56 GMT
Hi,

I am very new to ant and I've been trying to get wsdltodotnet task to work.
My build.xml looks like this:

<project default="create_cs">
    <target name="create_cs">
        <echo message="Hello World"/>
        <wsdltodotnet destfile="xoa.cs" srcfile="XOA.wsdl"/>
    </target>
</project>

I keep getting error=2, but I don't know what that means. I did many 
searched on Google and this mailing list, and I could not find any 
information that would help me resolve this. I tried running other 
tasks, and they all run fine, so I think ant is configured correctly. 
Here is the output I get when I run my build.xml with -d option
---------------------------------------------------------------------------------------------------------------------------
C:\Work\Java\Projects\WsdlTest>ant -v -f build.xml
Apache Ant version 1.6.5 compiled on June 2 2005
Buildfile: build.xml
Detected Java version: 1.4 in: C:\j2sdk_nb\j2sdk1.4.2\jre
Detected OS: Windows 2000
parsing buildfile C:\Work\Java\Projects\WsdlTest\build.xml with URI = 
file:///C:/Work/Java/Projects/WsdlTest/build.xml
Project base dir set to: C:\Work\Java\Projects\WsdlTest
Build sequence for target(s) `create_cs' is [create_cs]
Complete build sequence is [create_cs, ]

create_cs:
     [echo] Hello World
Executing 'wsdl' with arguments:
'/nologo'
'/out:C:\Work\Java\Projects\WsdlTest\xoa.cs'
'/language:CS'
'C:\Work\Java\Projects\WsdlTest\XOA.wsdl'

The ' characters around the executable and arguments are
not part of the command.

BUILD FAILED
C:\Work\Java\Projects\WsdlTest\build.xml:5: WSDL failed: 
java.io.IOException: CreateProcess: wsdl /nologo /out:C:\Work\J
ava\Projects\WsdlTest\xoa.cs /language:CS 
C:\Work\Java\Projects\WsdlTest\XOA.wsdl error=2
        at 
org.apache.tools.ant.taskdefs.optional.dotnet.NetCommand.runCommand(NetCommand.java:313)
        at 
org.apache.tools.ant.taskdefs.optional.dotnet.WsdlToDotnet.execute(WsdlToDotnet.java:230)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at org.apache.tools.ant.Main.runBuild(Main.java:668)
        at org.apache.tools.ant.Main.startAnt(Main.java:187)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
Caused by: java.io.IOException: CreateProcess: wsdl /nologo 
/out:C:\Work\Java\Projects\WsdlTest\xoa.cs /language:CS C:\W
ork\Java\Projects\WsdlTest\XOA.wsdl error=2
        at java.lang.Win32Process.create(Native Method)
        at java.lang.Win32Process.<init>(Win32Process.java:66)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.exec(Runtime.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at 
org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
        at 
org.apache.tools.ant.taskdefs.optional.dotnet.NetCommand.runCommand(NetCommand.java:304)
        ... 13 more
--- Nested Exception ---
java.io.IOException: CreateProcess: wsdl /nologo 
/out:C:\Work\Java\Projects\WsdlTest\xoa.cs /language:CS C:\Work\Java\Pr
ojects\WsdlTest\XOA.wsdl error=2
        at java.lang.Win32Process.create(Native Method)
        at java.lang.Win32Process.<init>(Win32Process.java:66)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.exec(Runtime.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at 
org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:834)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:435)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:449)
        at 
org.apache.tools.ant.taskdefs.optional.dotnet.NetCommand.runCommand(NetCommand.java:304)
        at 
org.apache.tools.ant.taskdefs.optional.dotnet.WsdlToDotnet.execute(WsdlToDotnet.java:230)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at org.apache.tools.ant.Main.runBuild(Main.java:668)
        at org.apache.tools.ant.Main.startAnt(Main.java:187)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

Total time: 1 second
-------------------------------------------------------------------------------------------------------------------------

Am I missing some key component or is it a misconfiguration issues? Any 
suggestions are greatly appreciated.

Danja


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message