ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob (Global Trade)" <Rob.Ander...@nike.com>
Subject RE: Sshexec task, running commands using 'sudo'
Date Wed, 15 Jun 2005 21:23:15 GMT
I recall seeing your post that you were not able to use sshexec even after your admin removed
the requirement for a password when running sudo for the command you were trying to run. I
have had success with this. I am able to use sshexec when sudo is configured to not require
a password for the command I need to run. If you are still prompted for a password, then sudo
is not configured as you want it. This is not a shortcoming of sshexec. It was designed to
be noninteractive. What would be the point of requiring a password, only to hard code it into
your build file, or elsewhere. There is no security in that method.

-Rob A

> -----Original Message-----
> From: S I [mailto:xiamak@hotmail.com]
> Sent: Tuesday, June 14, 2005 10:17 PM
> To: user@ant.apache.org
> Subject: RE: Sshexec task, running commands using 'sudo'
> 
> 
> You just discovered one of the shortcomings (or is it?) of 
> sshexec.  Even if 
> your Admin removes sudo's psswd, you will not be able to use 
> that ant task 
> as fars I know and been told by this forum.
> 
> However, couple of folks here, have mentioned that Antcontrib 
> (google or go 
> to sourceforge.net to get it) resolves this issue.  I 
> personally have not 
> got around to it or thank the person who posted and responded 
> to my post.
> 
> ----Original Message Follows----
> From: "Rich Harris" <rharris@shopping.com>
> Reply-To: "Ant Users List" <user@ant.apache.org>
> To: "Ant Users List" <user@ant.apache.org>
> Subject: RE: Sshexec task, running commands using 'sudo'
> Date: Tue, 14 Jun 2005 16:39:36 -0700
> MIME-Version: 1.0
> Received: from mail.apache.org ([209.237.227.199]) by 
> MC8-F3.hotmail.com 
> with Microsoft SMTPSVC(6.0.3790.211); Tue, 14 Jun 2005 16:34:24 -0700
> Received: (qmail 27055 invoked by uid 500); 14 Jun 2005 23:34:17 -0000
> Received: (qmail 26975 invoked by uid 99); 14 Jun 2005 23:34:17 -0000
> Received: neutral (hermes.apache.org: local policy)
> Received: from h-64-95-118-32.epinions.com (HELO 
> mail-na.shopping.com) 
> (64.95.118.32)  by apache.org (qpsmtpd/0.28) with ESMTP; Tue, 
> 14 Jun 2005 
> 16:34:12 -0700
> X-Message-Info: JGTYoYF78jHp5sTKoN4VgkILQjUXyhkDPw26qlheHiQ=
> Mailing-List: contact user-help@ant.apache.org; run by ezmlm
> Precedence: bulk
> List-Unsubscribe: <mailto:user-unsubscribe@ant.apache.org>
> List-Help: <mailto:user-help@ant.apache.org>
> List-Post: <mailto:user@ant.apache.org>
> List-Id: "Ant Users List" <user.ant.apache.org>
> Delivered-To: mailing list user@ant.apache.org
> X-ASF-Spam-Status: No, hits=1.8 
> required=10.0tests=DNS_FROM_RFC_ABUSE,DNS_FROM_RFC_POST,FORGED
> _RCVD_HELO
> X-Spam-Check-By: apache.org
> X-MimeOLE: Produced By Microsoft Exchange V6.5.6944.0
> Content-class: urn:content-classes:message
> X-MS-Has-Attach:
> X-MS-TNEF-Correlator:
> Thread-Topic: Sshexec task, running commands using 'sudo'
> Thread-Index: AcVxOKYgE2yfUe2NREmWln4u09cl4AAAREog
> X-Virus-Checked: Checked
> Return-Path: user-return-50648-xiamak=hotmail.com@ant.apache.org
> X-OriginalArrivalTime: 14 Jun 2005 23:34:24.0338 (UTC) 
> FILETIME=[98F7D320:01C57139]
> 
> An addendum...I noticed that when running 'sudo' commands 
> manually I get
> prompted for my password the first time I use it. That may be 
> where it's
> hanging. The uname/pass auth. only happens upon the initial 
> ssh connect
> using the sshexec and doesn't carry over through the session 
> if you need
> to run sudo. I would assume that since 'sudo' may be something widely
> used for administrative purposes there may be solution or fix for
> this....at least I hope so. :-)
> 
> Any help is appreciated.
> -Rich
> 
> 
> _____________________________________
> Rich Harris
> Release/Configuration Engineer
> rharris@Shopping.com
> 650-616-6866
> 
> Shopping.com(tm), Inc.
> Find. Compare. Buy.
> www.shopping.com
> 
> 
> -----Original Message-----
> From: Rich Harris [mailto:rharris@shopping.com]
> Sent: Tuesday, June 14, 2005 4:28 PM
> To: Ant Users List
> Subject: Sshexec task, running commands using 'sudo'
> 
> I'm having an issue where if I need to run 'sudo' before running a
> command during my ssh session, it just hangs ant until I escape out of
> ANT. Has anyone else had this problem? I'm open to ideas as 
> to why this
> is happening or how I can get around it while staying within the ANT
> environment.
> 
> Thanks,
> Rich
> 
> _____________________________________
> Rich Harris
> Release/Configuration Engineer
> rharris@Shopping.com
> 650-616-6866
> 
> Shopping.com(tm), Inc.
> Find. Compare. Buy.
> www.shopping.com <http://www.shopping.com/>
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message