ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernhard Rosenkraenzer <b...@arklinux.org>
Subject Errors while trying to compile ant 1.6.5 with gcj 4.0
Date Fri, 10 Jun 2005 20:57:50 GMT
Hi,
when trying to compile ant from source using gcj 4.0 (no non-free JDKs 
installed), hundreds of deprecation warnings and 2 fatal errors:

src/main/org/apache/tools/ant/IntrospectionHelper.java:495: error: No 
constructor matching 
'(org.apache.tools.ant.IntrospectionHelper,java.lang.Object,java.lang.Object)' 
found in class 'org.apache.tools.ant.IntrospectionHelper$NestedCreator'.
                   nc = new NestedCreator(null) {
                                                ^
src/main/org/apache/tools/ant/IntrospectionHelper.java: In class 
'org.apache.tools.ant.IntrospectionHelper$2':
src/main/org/apache/tools/ant/IntrospectionHelper.java: In constructor 
'(org.apache.tools.ant.IntrospectionHelper,java.lang.Object,java.lang.Object)':
src/main/org/apache/tools/ant/IntrospectionHelper.java:508: error: No 
constructor matching 
'(org.apache.tools.ant.IntrospectionHelper,java.lang.Object,java.lang.Object)' 
found in class 'org.apache.tools.ant.IntrospectionHelper$NestedCreator'.
                   nc = new NestedCreator(null) {
                                                ^
2 errors


Trying to use the ant binaries doesn't work either: ant -version results in
Unable to locate tools.jar. Expected to find it in /usr/lib/tools.jar
Apache Ant version 1.6.5 compiled on June 2 2005

AFAICT gcj doesn't have a tools.jar file.
Any ideas on this?

Thanks,
bero

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message