ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <david.k...@wamu.net>
Subject Ant 1.5.4: Why would one user get "TraxLiaison" and not do xslt correctly, and another user doesn't get "TraxLiaison" and it works
Date Sat, 25 Jun 2005 00:07:03 GMT
I built a build script that uses "style" to transform an XML file from
an XSLT.  It works fine for me.  When another particular user runs the
same script, with at least a similar environment, the transformation
appears to be a "noop".  My XSLT has a template that looks for a
particular element with a particular value, and if it finds it, it
generates particular output.  If it doesn't find it, it doesn't generate
those particular elements.  The difference in behavior between when I
run it, and when she runs it, makes it seem like it's able to find that
element when I run it, but not when she runs it.  Obviously, we're using
the same input and xslt files.

When I run the build, I see two lines of output related to the style
task, one says "Processing ...", and the other says "Loading stylesheet
...".  When this other person runs it, she sees an initial line that
says:

 [xslt] Using class org.apache.tools.ant.taskdefs.optional.TraXLiaison

I don't see this line when I run it.  It seems like this is important,
but I don't know what it means.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message