ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Altman <>
Subject Re: Problem with csc on OS X
Date Tue, 19 Apr 2005 00:54:30 GMT
I do not have Mono installed.  Is this a dependency for running Ant on 

If it is I will grab it, if it isn't I don't want to grab it and 
complicate matters.  :)

I didn't see it under the Lib Dependencies and I didn't see it under 
Platform Specific Issues...


On Apr 18, 2005, at 8:50 PM, Shatzer, Larry wrote:

> Do you have mono installed? If so, make sure that csc is in your path 
> (by
> editing the correct startup script, such as .bashrc).
> -- Larry 
> -----Original Message-----
> From: Chris Altman []
> Sent: Monday, April 18, 2005 5:46 PM
> To:
> Subject: Problem with csc on OS X
> I am currently trying to build a .NET application on my OS X box.  I
> have it successfully building on my WinXP box so, I am confident the
> build.xml is correct.
> The issue arises with csc.
> It returns this error: csc failed: mcs: not found
> Now I have read through some of the other messages and noticed that
> this has also happened to those on WinXP and the solution for the most
> part was to add csc.exe to the PATH variable.  However, I am not even
> sure that is possible on OS X?
> I have also seen something about needing ant-nodeps.jar but have had 0
> luck finding this file other then in my lib folder?  Is there a way I
> need to register it, or get a newer version?  I am running Ant 1.6.2.
> Thanks in advance for the help!!
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message