ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: IllegalAccessException
Date Fri, 11 Mar 2005 15:20:58 GMT
On Fri, 11 Mar 2005, Don J. Payette <Don.Payette@unisys.com> wrote:
> This
>     <java jvm="/-/${JAVA_PACK}/OBJECT/JAVA">
>     </java> 
> works.  Correct about /bin/java not working.
> 
> I added
>     <echo>"java.home '${java.home}'"</echo>
>     <echo>"os.name '${os.name}'"</echo>
> and got
>      [echo] "java.home '/-/JAVA142/DIR/JRE'"      
>      [echo] "os.name 'MCP/AS'"                    
> 

Interesting, thanks.  Is ${JAVA_PACK} the same as ${java.home} or
where does it point?

> This gave me the idea to copy OBJECT/JAVA as
> /-/JAVA142/DIR/JRE/BIN/JAVA and remove the jvm= line.  So I tried
> it.  It still doesn't work.

Is the file system case sensitive?  Or maybe Java thinks it is (and
this considers /-/JAVA142/DIR/JRE/BIN/JAVA and
/-/JAVA142/DIR/JRE/BIN/java to be different.

What was the "normal" name of the OS (so if we fix it we know what to
put into the docs).

> Here's what happens without the jvm= workaround:
> 
> -     % #1: (DONP)LIST/STDERR ON SYSTEM (Records: 1-31 of 31)

No idea, sorry.

If you run Ant with -verbose you may get an idea of what Ant is trying
to do.  Maybe you can find something that looks wrong for your
platform.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message