ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maciej Zywno <m.zy...@gmail.com>
Subject Re: why MyClass.class.getPackage returns null when ant classloader is used?
Date Thu, 10 Mar 2005 09:42:00 GMT
Thanks, but could you say more about it? I checked that ant
classloader does not override getPackage method, so the same
method(i.e. ClassLoader.getPackage) is used when using both ant and
sun classloaders. Does the problem have sth to do with classpaths?
Regards,
Maciek


On Thu, 10 Mar 2005 10:31:40 +0100, Stefan Bodewig <bodewig@apache.org> wrote:
> On Thu, 10 Mar 2005, Maciej Zywno <m.zywno@gmail.com> wrote:
> 
> > I've come across strange error in my app. The error is connected
> > probably with ant classloader and appears while the following piece
> > of code in my application is run from junit (triggered by ant
> > triggered by maven):
> >
> >  MyClass.class.getPackage
> >
> > returns null,
> 
> Maven still uses Ant 1.5.4 IIRC.  Ant 1.6.x (1.6.0 has been released
> more than a year ago) is supposed to provide package information.
> 
> I have no idea whether you can run Maven with Ant 1.6.x.
> 
> Stefan
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message