ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doklovic, Jonathan" <JDoklo...@VSCat.com>
Subject RE: NoClassDefFoundError for class that is on the classpath?
Date Thu, 31 Mar 2005 14:04:17 GMT
What does your <junit> entry look like? 

-----Original Message-----
From: F Da Costa Gomez [mailto:dacostagomez@gmail.com] 
Sent: Thursday, March 31, 2005 7:53 AM
To: user@ant.apache.org
Subject: NoClassDefFoundError for class that is on the classpath?

Hi,

Following the error i get when trying to run a script (from Eclipse 3.0.2)

jmlUnitTestStubs:
      [java] java.lang.NoClassDefFoundError: org/jmlspecs/jmlunit/Main
      [java] Exception in thread "main"

The class is actually *on* the classpath because the following line in
echo-ed:
...
C:/eclipse/plugins/org.jmlspecs_1.0.4/jml-release.jar;
C:/eclipse/plugins/org.jmlspecs_1.0.4/jml-specs;

Actually it can be found in the release.jar

The code used to set the classpath is as follows <snip>
<!-- Set the classpath for the project, include the JML spec-files as well
--> <path id="classpath">
  <pathelement path="${java.class.path}" />
  <fileset dir="${jmlhome}/bin">
   <include name="**/*.jar"/>
  </fileset>
  <fileset dir="${test.dir}">
   <include name="jmlfiles.jar"/>
  </fileset>
</path>
		
<pathconvert property="cp" refid="classpath" dirsep="/" pathsep=";"/>
</snip>

Could anybody point a the right direction to resolve this?

tia,

Fermin DCG


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional
commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message