ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <>
Subject Re: Different <style> behaviour between 1.5.3 and 1.6.2
Date Wed, 02 Mar 2005 22:54:24 GMT
Hello Ralf,

I remember having had a strange similar problem, I think the style task 
was trying to generate output for me twice, once properly and then with 
a flat directory structure.
Can you search in bugzilla ( to see 
whether someone else has reported this bug. If not, then please file a 
bug report, otherwise you can
add yourself as CC on the existing bug report, or even dig into the code 
and propose us a fix.



Ralf Schandl wrote:

>I have a problem with the style task and a stylesheet that creates files
>by its own. The stylesheet I use translates a docbook source file into a
>help file structur for eclipse. It creates a "toc.xml" in the base dir
>and a subdirectory "doc/" for the individual html files.
>I use the following ant target:
><target name="plugin-doc"
>     description="Create the plugin documentation">
>    <style
>	basedir="${docsrc.dir}/xml"
>	includes="doc.xml"
>	destdir="${plugin.out.dir}"
>	style="${basedir}/stylesheets/eclipsestyle.xsl"
>	classpath="${basedir}/lib/saxon.jar"
>	processor="trax">
>    </style>
>	....
>After this I expect to find the following structure:
>/${plugin.out.dir}/doc.xml	(empty, deleted later)
>This works as expected using ANT V1.5.3.
>If I use ANT V1.6.2 it doesn't work. Instead I get:
>/${plugin.out.dir}/doc.xml	(empty, deleted later)
>What is going on here?
>Additional Info:
>- Ant 1.5.3 what included in WSAD 5.1.2
>- Ant 1.6.2 came with Eclipse 3.0.1
>- Same behaviour if I call Ant from Eclipse/WSAD or from the
>  command line.
>- The stylesheet I use is from the docbook xsl distribution from 
>  Norman Walsh (
>	Ralf

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message