ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob (Global Trade)" <Rob.Ander...@nike.com>
Subject RE: Ant Exception Error
Date Wed, 02 Mar 2005 22:04:44 GMT
Ah yes. Someone posted it to this list recently. Here is the relevent info...


Q: How do you get ant-1.6x (or versions later than 1.5.2-23) to work on 
on RedHat ES 3?

A: Redhat ES 3.0 comes installed with ant 1.5.2. Even if you have your 
PATH and ANT_HOME variables set correctly to a later version of ant, you 
will always be forced to use the preinstalled version.

To use a later version of ant on this OS you could do the following:
# ant -version
Apache Ant version 1.5.2-23 compiled on November 12 2003
# su -
# rpm -e ant ant-libs
# exit
# hash -r
# ant -version
Apache Ant version 1.6.2 compiled on July 16 2004



> -----Original Message-----
> From: Anderson, Rob (Global Trade) [mailto:Rob.Anderson@nike.com]
> Sent: Wednesday, March 02, 2005 2:03 PM
> To: Ant Users List
> Subject: RE: Ant Exception Error
> 
> 
> I have heard that you need to uninstall the ant rpm that came 
> with the distro in order to use a different version. I have 
> not confirmed this, but it might be worth a try.
> 
> -Rob Anderson
> 
> > -----Original Message-----
> > From: Dean N. Williams [mailto:williams13@llnl.gov]
> > Sent: Wednesday, March 02, 2005 6:58 AM
> > To: user@ant.apache.org
> > Subject: Ant Exception Error
> > 
> > 
> > Dear Ant community,
> > 
> > 	I am new to Ant and trying to build Ant 1.6.1 or 1.6.2. 
> > I am on a RedHat Linux Enterprise WS platform.
> > I am trying both methods of installation. That is, 
> > apache-ant-1.6.1-src.zip
> > apache-ant-1.6.2-bin.tar.gz 
> > 
> > Both methods result in the following error message.
> > 
> > ./ant -version
> > Exception in thread "main" java.lang.NoClassDefFoundError: 
> > org/apache/tools/ant/launch/Launcher
> > 
> > 	When I use the Ant 1.5.2 that came with the system it 
> > works. I get:
> >  /usr/bin/ant -version
> > Apache Ant version 1.5.2-23 compiled on November 12 2003
> > 
> > What am I missing for Ant 1.6.1 to work?
> > 
> > Thanks in advance for your help...
> > 
> > Best regards,
> > 	Dean
> > 
> > 
> > 
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > For additional commands, e-mail: user-help@ant.apache.org
> > 
> > 
> > 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message