ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Travis Cripps <tra...@apparentmotion.com>
Subject Re: Class org.apache.tools.ant.types.PatternSet$NameEntry doesn't support the "value" attribute.
Date Fri, 18 Feb 2005 19:36:08 GMT
Stefan,

On Feb 14, 2005, at 6:46 AM, Stefan Bodewig wrote:

> On Fri, 11 Feb 2005, Travis Cripps <travis@apparentmotion.com> wrote:
>
>> Hi.  I've got a strange error in my build script, and I've been
>> unable to find references to the error code in extensive searches on
>> the internet.
>
> From your subject line, I'd say you have an include or exclude element
> with a value attribute instead of name.
>
> Since you only posted what you considered the relevant snippets,
> please point us at line 255 in generic.xml.

Line 255 of my generic.xml file was:

  <wocompile srcdir="${project.dir}" destdir="${build.classes}" 
debug="on" optimize="off" deprecation="on">

As you suggested, I did have a spurious value parameter in my include 
statement, causing the xml parser to blow up:

<include name="OpenBasePKPlugIn.framework" value="true" />

Removing the offending value statement fixed the problem. :)

Thank you very much for your suggestion!  In hindsight it should have 
been more obvious what, but I was so fixated on the problem being on 
line 255 that I didn't look closely enough at the rest of the task 
definition.

Once again, thank you!

Travis


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message