ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey E Care <ca...@us.ibm.com>
Subject Re: Symbolic Link with ANT
Date Tue, 22 Feb 2005 19:55:23 GMT
<target name="link">
  <exec executable="/bin/ln" >
    <arg value="-s"/>
    <arg value="${basedir}/one.txt"/>
    <arg value="${basedir}/two.txt"/>
  </exec>
</target>
-- 
Jeffrey E. Care (carej@us.ibm.com)
WebSphere Build SWAT Team Lead
WebSphere Build Tooling Lead (Project Mantis)
https://w3.opensource.ibm.com/projects/mantis


"Madhu ." <emadhu@hotmail.com> wrote on 02/22/2005 02:48:46 PM:

> 
> I am trying to create a symbolic link using the target below;
> 
>   <target name="link">
>    <exec executable="/bin/ln -s" >
>        <arg value="${basedir}/one.txt"/>
>        <arg value="${basedir}/two.txt"/>
> 
>    </exec>
>    </target>
> 
> However it is throwing the exception below.
> 
> BUILD FAILED
> file:/ms/.global/ny.w/user/m/madhue/build.xml:15: Execute failed: 
> java.io.IOException: /bin/ln -s: not found
> Do i need to set any shell paths for the build file?
> 
> Linux version:  2.4.9-e.34enterprise
> 
> can some one let me know whats wrong with the target above.
> 
> Sam
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message