ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darin Swanson <Darin_Swan...@us.ibm.com>
Subject Re: AW: AW: problem with javadoc
Date Fri, 11 Feb 2005 19:43:18 GMT
<likely better in an Eclipse forum....eclipse.platform newsgroup>

The JRE/JDK used for an Ant build in Eclipse is specified on the JRE tab 
of the Ant launch configuration.
It uses the default install as specified in the installed JREs preference 
page (or the project specific JRE settings if different from the global 
preference).

You can set the build to occur in any JRE/JDK you require by configuring 
on the JRE tab of the Ant launch configuration.

One difference: if you are building in the same JRE as Eclipse...then you 
need to do as Jan indicated: start eclipse with the appropriate -vm option 
to point to the JRE/JDK you wish to run Eclipse (and therefore same JRE 
Ant builds). Generally a build does not need to occur in the same JRE as 
Eclipse.

HTH
Darins




James Abley <james.abley@volantis.com> 
02/11/2005 11:35 AM
Please respond to
"Ant Users List"


To
Ant Users List <user@ant.apache.org>
cc

Subject
Re: AW: AW: problem with javadoc






On Fri, 2005-02-11 at 12:58, Jan.Materne@rzf.fin-nrw.de wrote:
> AFAIK Eclipse starts with the Java where JAVA_HOME points to,
> if you dont provide another one via -vm option.
> 
> Jan
> 

If you look in Window | Preferences, under the Java option there should
be an "Installed JREs" entry. You can check what you are using there.

James

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message