ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <DDevie...@lgc.com>
Subject RE: cannot connect to socket: Connection refused
Date Thu, 17 Feb 2005 16:28:51 GMT
Do you need a colon before pserver too?

You need one after the port number as well, unless 2401 is the default
CVS port as Rob implies. --DD

> -----Original Message-----
> From: Anderson, Rob (Global Trade) [mailto:Rob.Anderson@nike.com]
> Sent: Thursday, February 17, 2005 10:24 AM
> To: Ant Users List
> Subject: RE: cannot connect to socket: Connection refused
> 
> Your CVSROOT is not set properly. Change it too...
> 
> ...
> <cvspass cvsRoot="pserver:sachinp@192.X.X.X:/home/gtekcvs"
>  password="${user.cvspass}"/>
>  	<cvs cvsRoot="pserver:sachinp@192.X.X.X:/home/gtekcvs"
>  		 command="-Q checkout"
>  		 package="Xpan/src"
>  		 dest="${src.dir}"
>  		 failonerror="true">
>  	</cvs>
> 
> -Rob Anderson
> 
> > -----Original Message-----
> > From: Pritesh Saharey [mailto:priteshsaharey@sify.com]
> > Sent: Thursday, February 17, 2005 3:40 AM
> > To: Ant Users List
> > Subject: cannot connect to socket: Connection refused
> >
> >
> > Hi All,
> >     I am trying to checkout the package from CVS using ant
> > from Windows 2000 m/c, my cvs.exe is in path. Below is the
> > snipte of code which Iam using
> > <target name="cvsget-source"
> > 	description="getting the latest source code from CVS">
> > 	<record name="CVS.log" action="start"/>
> > 	<cvspass
> > cvsRoot="pserver:sachinp@192.X.X.X:2401/home/gtekcvs"
> > password="${user.cvspass}"/>
> > 	<cvs cvsRoot="pserver:sachinp@192.X.X.X:2401/home/gtekcvs"
> > 		 command="-Q checkout"
> > 		 package="Xpan/src"
> > 		 dest="${src.dir}"
> > 		 failonerror="true">
> > 	</cvs>
> > 	<record name="CVS.log" action="stop"/>
> >
> > </target>
> >
> > After running the build.xml file it is giving me error like this:
> > [cvs] Using cvs passfile: C:\Documents and
> > Settings\Administrator\.cvspass
> > [cvs] cvs [checkout aborted]: cannot connect to socket:
> > Connection refused
> > [cvs]
> > [cvs]
> >
> > BUILD FAILED
> >
> > C:\downloads\gtek\build.xml:51: cvs exited with error code 1
> > Command line was [Executing 'cvs' with arguments:
> > '-dpserver:sachinp@192.X.X.X:2401/home/gtekcvs'
> > '-Q'
> > 'checkout'
> > 'Xpan/src'
> >
> > The ' characters around the executable and arguments are
> > not part of the command.
> >
> > Can anybody guss what I am doing wrong?
> > Any Help  would be higly appreciated.
> >
> > Regards
> > pritesh
> >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message