ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Giguere <eric.gigu...@videotron.ca>
Subject Re: Creation of an executable jar problem
Date Tue, 01 Feb 2005 17:44:48 GMT
Do you have your Main-Class entry in the manifest?

HTH.
Eric.

Eric Rotick wrote:

>I've created an executable jar. When I run it with
>
>java -jar myjar.jar
>
>I get the NoClassDefFoundError: error.
>
>I've looked in the list archives and there are several posts about ant
>not creating an executable jar correctly but none of these come to any
>real conclusion as to why.
>
>I've extracted the jar and everything looks OK. I then created a new
>jar from the command line with the extracted contents and this works.
>
>One other thing is that the sizes of the two jars are different. If a do a
>
>jar tvf 
>
>on each of them, the contents are exactly the same size.
>
>I'm not creating a jarindex on either of them and I make sure that
>both are compressed or both are not. When compressed the difference is
>about 100 bytes and when not compressed the difference is 8 bytes.
>
>Any ideas.
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>
>  
>



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message