ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lieve Van den Heuvel" <>
Subject RE: CVS command with Ant in IntelliJ
Date Fri, 28 Jan 2005 11:02:28 GMT
Thank you thank you thank you

That seemed to be the problem.. IntelliJ used the system path from its
startup point..

Thank you all very much!


>>> 28/01/2005 11:42:12 >>>
Try to take care of this PATH at the system environment level. Make
cvs is found is the $PATH ot %PATH% when you open a DOS cmd or Unix
shell. This will fix PATH on IntelliJ like tools, as the system
environment is pre-set.

-----Original Message-----
From: Lieve Van den Heuvel [] 
Sent: Friday, January 28, 2005 5:36 AM
Subject: Re: CVS command with Ant in IntelliJ

Hi James

Thank you for your answer but I know that the exec command doesn't
the thing work but it was just one of my try-outs..  I tried to add
path to the cvs.exe in IntelliJ but it seems that he doesn't find it
afterall and that's the thing that's causing me these frustrations.

So is there any other way to indicate to ant where the cvs.exe is

Thank you very much!

>>> 28/01/2005 11:28:54 >>>
On Fri, 2005-01-28 at 10:17, Lieve Van den Heuvel wrote:
> Hi,
> I'm just new to the mailing list but I'm experiencing a very
> "frustrating" problem.  I've written a buildscript for our project
> I'm not able to execute a cvs-command in the buildfile.
> The environment I'm working in:
> Ant: 1.6.2
> CVSNT (from winCVS -> latest stable version)
> Idea IntelliJ 4.5.3
> When I try to execute the target at the command line, everyting
> perfectly.  The error I get is:
> Caught exception: CreateProcess: cvs

> update -d -l ids/java error=2
> I know what the exception means, he can't find the cvs.exe.  I
> tried to set it as an additional path for the ant execution ->
> work, I also
> tried to run a command file before the execution, setting the path
> didn't work, so now I'm pretty much out of ideas to figure out what
> going wrong.
> Does anybody have any idea what could cause this problem?
exec causes a new instance of your shell to run, and sets up
variables for that instance, hence any changes aren't persisted when
exec task ends.

Is there a particular reason you can't add the location of the cvs
executable to the system PATH or user PATH, as suggested in 

> I would be very very thankful for your answer!
> This is a part of the build file:
> <!-- The files contains the cvs.repository property
> -->
> <property file="conf/"/>
> <property name="cvs.package.dependencies" value="ids/java/lib"/>
> <property name="cvs.package.conf" value="ids/java/conf"/>
> <target name="set.environment">
>         <exec dir="${basedir}/${conf.dir}" executable="cmd.exe">
>             <arg value="/c setenv.cmd"/>
>         </exec>
> </target>
> <target name="dependencies" depends="set.environment"
> description="Update the external libraries that are used from CVS">
>         <cvs command="update -d" cvsroot="${cvs.repository}"
> package="${cvs.package.dependencies}" dest="."/>
>         <cvs command="update -d" cvsroot="${cvs.repository}"
> package="${cvs.package.conf}" dest="."/>
>         <cvs command="update -d -l" cvsroot="${cvs.repository}"
> package="ids/java" dest="."/>
> </target>
> Greetz
> Lieve
> To unsubscribe, e-mail: 
> For additional commands, e-mail: 

To unsubscribe, e-mail: 
For additional commands, e-mail: 

To unsubscribe, e-mail: 
For additional commands, e-mail: 

View raw message