ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Re: ${ant.home} partly broken in Ant 1.6.2 - also ${ant.library.dir}
Date Tue, 04 Jan 2005 18:42:41 GMT
I've downloaded and installed Ant 1.6.2 from apache.org and reset my
ANT_HOME environment variable to point to the new Ant 1.6.2 instead of Ant
1.6.1. I opened a command prompt (I'm in WinXP) and ran my build file with
the ${ant.home} line enabled; the build worked perfectly and both of the
imports worked as well.

In short, the problem I'm having seems to be isolated to Ant 1.6.2 within
Eclipse.

All of you who said it was an Eclipse problem appear to have been correct
;-) I'll pursue this problem with the Eclipse folks.

Rhino

----- Original Message ----- 
From: <Kajsa.Anderson@thomson.com>
To: <user@ant.apache.org>
Sent: Tuesday, January 04, 2005 11:58 AM
Subject: RE: ${ant.home} partly broken in Ant 1.6.2 - also
${ant.library.dir}


I did a bit of experimenting with this, and it does seem to be an Eclipse
issue.  It looks to me like it's a problem with the Eclipse Ant editor
trying to resolve the filename without first resolving properties in the
filename.  If so, that would explain why your work-around works.

Rhino, have you tried running your build file from command-line Ant, or only
from within Eclipse?

HTH,

Kajsa Anderson

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message