ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "h2ooo x" <tj...@hotmail.com>
Subject Classpath when executing JAR
Date Tue, 12 Oct 2004 06:25:08 GMT
Hi!

I have the following Ant (1.6.2) tasks defined,

  <path id="runtime-classpath">
    <pathelement location="${dist}/myproject.jar"/>
    <pathelement location="${lib}/commons-logging-api.jar"/>
    <pathelement location="${lib}/commons-logging.jar"/>
    <pathelement location="${lib}/commons-httpclient-2.0.2.jar"/>
  </path>

  <target name="run" depends="jar">
    <java classname="MyClass" classpathref="runtime-classpath" fork="true">
    </java>
  </target>

  <target name="run2" depends="jar">
    <java jar="${dist}/myproject.jar" classpathref="runtime-classpath" 
fork="true">
    </java>
  </target>


The task "run" is executed correct but the task "run2" produced the 
following error:

  run2:
       [java] java.lang.NoClassDefFoundError: 
org/apache/commons/httpclient/HttpMethod
       [java] Exception in thread "main"
       [java] Java Result: 1


Do you have any idea what could be the problem?

_________________________________________________________________
Using a handphone prepaid card? Reload your credit online! 
http://www.msn.com.my/reloadredir/default.asp


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message