ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Redl <wasti.r...@gmx.net>
Subject Re: Ant 1.6.2 failing to bootstrap
Date Sat, 16 Oct 2004 14:36:34 GMT
Laconia Data Systems wrote:

>Sounds like you have an adapter missing..this solution works when compiling
>ANT scripts within Eclipse:
>add the following property before compiling:
><property name="build.compiler"
>value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
>Martin-
>  
>
I don't think so. It's attempting to use the standard compiler, and the 
line that fails in CompilerAdapterFactory.java is just:
Class.forName(MODERN_COMPILER);
where MODERN_COMPILER is defined to be "com.sun.tools.javac.Main".

Besides, modifying build files is not an option. This problem occurs 
with every project that uses Ant, including Ant itself.

Sebastian Redl

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message