ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laconia Data Systems" <webmas...@laconiadatasystems.com>
Subject Re: Classpath Issue - Not sure why it isn't being picked up
Date Wed, 06 Oct 2004 11:30:52 GMT
Grand:
Keep in mind that if your base folder is named 'base' and
your package name is named 'foo' then you need to compile the source from
folder 'base' which referennces package (folder) foo
Since your email did not provide package names I do not know what the
specific names would be
Martin
----- Original Message -----
From: "Grand Cheng" <grand.c@pointclickcare.com>
To: <user@ant.apache.org>
Sent: Tuesday, October 05, 2004 4:22 PM
Subject: Classpath Issue - Not sure why it isn't being picked up


Hi,



I am a newbie to Ant so I appreciate any help you can lend me.



I am trying to compile a fairly large project, which has multiple
packages, and has referencing between them.  So when I first created the
build file and ran it, I received a slew of "package not found" , and
"cannot resolve symbol"



I then added the following to my build file.



<path id="mypath.path">

<pathelement path ="${basedir}\source\a" />

<pathelement path ="${basedir}\source\b" />

<pathelement path ="${basedir}\source\c" />

</path>



I have basically added a pathelement for every folder within my
project...just to make sure I haven't missed anything.



I have a target



<target name="CompileMyStuff">

<javac srcdir="${basedir}\source\a" />

<classpath refid="${mypath.path}" />

</target>



However, when I run this, I still receive the same "package not found" ,
and "cannot resolve symbol"





I am using Ant v. 1.6.2 and JDK 1.3.1_04



Thanks for your help







---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message