ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian.Kon...@deltalloyd.de
Subject Antwort: AW: passing 0 to exec
Date Wed, 29 Sep 2004 11:21:14 GMT

Yes you're right, Jan!
It's not Ant, it's Perl. The problem occurs when receiving the argument.
Sorry for bothering you.

Christian




|---------+---------------------------->
|         |           Jan.Materne@rzf.f|
|         |           in-nrw.de        |
|         |                            |
|         |           29.09.2004 12:14 |
|         |           Bitte antworten  |
|         |           an "Ant Users    |
|         |           List"            |
|         |                            |
|---------+---------------------------->
  >--------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                       |
  |       An:       user@ant.apache.org                                                  
                       |
  |       Kopie:                                                                         
                       |
  |       Thema:    AW: passing 0 to exec                                                
                       |
  >--------------------------------------------------------------------------------------------------------------|




works for me

Jan


<target name="perltest">
    <exec executable="perl">
        <arg value="test.pl"/>
        <arg value="0"/>
    </exec>
</target>

foreach $arg (@ARGV) {
    print "- $arg\n";
}



C:\TEMP\anttest>ant perltest
Buildfile: build.xml

perltest:
     [exec] - 0

BUILD SUCCESSFUL
Total time: 0 seconds


> -----Urspr√ľngliche Nachricht-----
> Von: Christian.Konrad@deltalloyd.de
> [mailto:Christian.Konrad@deltalloyd.de]
> Gesendet am: Mittwoch, 29. September 2004 11:55
> An: user@ant.apache.org
> Betreff: passing 0 to exec
>
> Hi,
>
> I'm calling a perl script using the exec task. But it seems
> like ant does
> not handle passing the value "0" as an argument to exec.
> Am I right?
>
> exec ...
>      arg value=0
> /exec
>
> In the upper case the perl script doesn't receive a value.
> Other passed
> numbers are accepted.
> Thanks in advance,
>
> Christian Konrad
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>






---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message