ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean D (Dean)" <dhil...@avaya.com>
Subject junit taskdef not working? is this working for others...
Date Sat, 11 Sep 2004 19:54:48 GMT
First the simple question, then the one that possibly should be asked on
the developer list

 

Why would this not be working and still complaining it can't find a
class in the junit jar

            <path id="junit.lib">

                        <pathelement
path="${junit.location}/ant-junit.jar"/>

                        <pathelement path="${lib}/tools/junit.jar"/>

            </path>

      <taskdef name="junit"
classname="org.apache.tools.ant.taskdefs.optional.junit.JUnitTask"

               classpathref="junit.lib"/>

 

 

especially since I comment out the taskdef and do the following....

---------------------------------------------------------

        <!--generate string on what jars got included for debugging-->

        <pathconvert dirsep="/" pathsep=" " property="temp.string"
refid="junit.lib" setonempty="true"/>

      <echo message="junit=${temp.string}"/>

 

which tells me the exact location, so I go verify the locations and they
are there.  What is more interesting is I have not ANT_HOME set.  And I
don't have optional.jar not ant-junit.jar in ant/lib.  Ps. Why is there
an optional.jar there in ant1.6.2??  I thought optional was supposed to
be gone.  Optional.jar contained some of the same classes that
ant-junit.jar did.

Thanks for any suggestions here including pointing a stupid typo or
something.  I keep staring at this.  Just want to make sure it is
working for other people.

Thanks,

dean


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message