ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Reilly <peterrei...@apache.org>
Subject Re: Taskdef classpath problem
Date Mon, 27 Sep 2004 08:19:07 GMT
Can you come up with a small build file + sources that shows the problem.

There are a number of issues with classpath and taskdefs, but it should be
possible to workaround your problem.

Peter

Guru Balse wrote:

>Just wondering if anyone else has run into this.  In an effort to keep the build and test
environments clean, we diligently blanked out the classpath and used a refid everywhere to
point to the correct classpath (in <taskdef>, <java>, etc.)
>
>The strange problem we are facing is that even though we can clearly see class X.Y.Z in
the classpath (through refid and a java program that inspects jars/zips in the classpath),
the task code dies with a ClassNotFound.
>
>If we set the env classpath to the same string obtained by echoing the classpath that
the taskdef sees, then everything works fine!
>
>Looks like there may be a bug in the taskdef class loading algo?
>
>Has anyone seen this?  Any workarounds?
>
>Thanks.
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>For additional commands, e-mail: user-help@ant.apache.org
>
>
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message