ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "PAUL, SATYAJIT" <satyajit_p...@hp.com>
Subject facing problem while integrating ant with eclipse(2.1.1)
Date Fri, 20 Aug 2004 13:25:14 GMT
Hi,

I am trying to use an external ant script from eclipse (version 2.1.1) and facing hurdle at
one step, I am not able to use the task "ftp" which comes with commons-net-1.1.0.jar. I am
successfully using the tag with ant 1.6.1 but if I want to run the same script from eclipse
it fails. <ftp> tag is directly not supported by apache-ant-1.6.1, u need to put one
plug-in commons-net-1.1.0.jar under ANT_HOME/lib and it works fine. 

Let me give a try to explain it little bit more......

I am using    eclipse 2.1.1 which uses ant 1.5.3 internally. So, naturally this doesn't support
the <ftp> which comes only with commons-net-1.1.0.jar. So, I referred this jar in the
classpath of the eclipse's "external build tool" option, still did not work. Seems commons-net-1.1.0.jar
needs commons-net.jar's help to be called or used.  So, now I am pointing the eclipse classpath
to whole of lib of ant 1.6.1 but still not working, in fact nothing comes to the console not
even the earlier encountered massage which points to ftp task

"[ftp] BUILD FAILED: file:build_apBolton.xml:203: Could not create task or type of type: ftp."



Thanks & Regards,
satya

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message