ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Ivanov <>
Subject Re: A Newbie question ...
Date Wed, 11 Aug 2004 12:12:12 GMT
Could you try with this steps
0)  Check whether you have a preinstalled ant on your
machine. Some Linux distributions come with older ant
version and you might have such installed (assuming
your shell is bash)
1) Export JAVA_HOME to you jdk installation folder
2) Export ANT_HOME and *do not* export classpath
ant starting script is clever enough to configure the
classpath it needs by itself
3) Check your ant with this command
$ANT_HOME/bin/ant -version
it should give you the version of your ant.

If 3) works you can run ant with your build scripts

P.S. And when you make ant work you can set it in your
PATH for easier invocation:
export PATH=$PATH:$ANT_HOME\bin

--- Ashish Agnihotri <> wrote:

> Hi there,
> I am a newbie with Ant. I am trying to run ant on my
> UNIX box. But whn I try
> to run the task – I get the following error .
> XML parser factory has not been configured
> correctly: Provider for
> javax.xml.parsers.SAXParserFactory cannot be found
> Can anyone help me with this? Here are the steps I
> followed for the
> installation of Ant (1.5.1) –
> 1.	Unzipped the archive in a directory in my user
> home under the folder ‘ant
> ’
> 2.	Set the ANT_HOME env veriable.
> 3.	Set the JAVA_HOME env variable.
> 4.	Set the CLASSPATH in the .profile path to the
> $ANT_HOME/lib
> Thanks in advance.
> Regards,
> - Ashish

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message