ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angeshwar Deepak <angesh...@yahoo.com>
Subject RE: <for> -Build Failed:problem
Date Mon, 02 Aug 2004 14:28:16 GMT
Hi,

I searched for the xml file u mentioned to. Its
available onliny in ant-contrib-1.0b1 (the latest
version). In the previous versions there is no such
xml file.

Also the taskdef task takes only a classfile as
attribute. I cannot understand how it takes a xml
file. Could u please give me an example of how u used
it.

bye,
with regards,
Deepak.


--- "Khehra, Sukh" <Sukh.Khehra@wsj.com> wrote:

> properties file is needed in ant 1.5 versions i
> think. try it with the xml file. i have it running
> quite well.
> 
> 
> -----Original Message-----
> From: Angeshwar Deepak [mailto:angeshwar@yahoo.com]
> Sent: Monday, August 02, 2004 10:00 AM
> To: Ant Users List
> Subject: RE: <for> -Build Failed:problem
> 
> 
> Hi,
> 
> In the site
> 
> http://ant-contrib.sourceforge.net/
> 
> Under installation its mentioned to include the line
> 
> <taskdef
> resource="net/sf/antcontrib/antcontrib.properties"/>
> 
> If u want to use ant-contrib tasks.
> kindly correct me if I am wrong.
> 
> 
> bye,
> with regards,
> Deepak.
> 
> 
> --- "Khehra, Sukh" <Sukh.Khehra@wsj.com> wrote:
> 
> > shouldn't you say <taskdef
> > resource="net/sf/antcontrib/antlib.xml"> ?
> > 
> > -----Original Message-----
> > From: Angeshwar Deepak
> [mailto:angeshwar@yahoo.com]
> > Sent: Monday, August 02, 2004 6:14 AM
> > To: Ant Users List
> > Subject: RE: <for> -Build Failed:problem
> > 
> > 
> > Hi,
> > 
> > I tried that too, but still it does'nt work. But
> > for-each task works, the problem is only with for
> > task.
> > 
> > So I am still breaking my head.
> > 
> > bye,
> > with regards,
> > Deepak.
> > --- Nanda Kishore MVS
> > <nandakishoremvs@renaissance-it.com> wrote:
> > 
> > > Hi,
> > > 	No, I meant the lib folder straight. In your
> case
> > > like:
> > > SET
> > >
> >
>
CLASSPATH=D:\deepak\buildProcess_2\_tools\ant-1.6.2\lib;%CLASSPATH%
> > > The lib folder itself should be in classpath,
> not
> > > the contrib jar alone.
> > > As for why it's so, I've not looked into that,
> but
> > > this is how the contrib tasks are working for me
> > > now.
> > > 
> > > Regards,
> > > Nanda Kishore
> > > 
> > > 
> > > -----Original Message-----
> > > From: Angeshwar Deepak
> > [mailto:angeshwar@yahoo.com]
> > > Sent: Monday, August 02, 2004 3:12 PM
> > > To: Ant Users List
> > > Subject: RE: <for> -Build Failed:problem
> > > 
> > > 
> > > Hi,
> > > 
> > > Do you mean to say this?-I have it I guess.
> > > 
> > > SET
> > >
> >
>
CLASSPATH=D:\deepak\buildProcess_2\_tools\ant-1.6.2\lib\ant-contrib-0.6.jar;
> > > 
> > > and my complete set of classpath is
> > > 
> > > SET
> > >
> >
>
PATH=c:\j2sdk1.4.2_04\bin;D:\deepak\buildProcess_2\_tools\ant-1.6.2\bin;D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin\bin
> > > set JAVA_HOME=c:\j2sdk1.4.2_04
> > > set
> > >
> ANT_HOME=D:\deepak\buildProcess_2\_tools\ant-1.6.2
> > > set
> > >
> >
> PATH=%PATH%;%ANT_HOME%\bin;%PATH%;%FORREST_HOME%\bin
> > > 
> > > set
> > >
> >
>
FORREST_HOME=D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin
> > > SET
> > >
> >
>
CLASSPATH=D:\deepak\buildProcess_2\_tools\ant-1.6.2\lib\ant-contrib-0.6.jar;
> > > 
> > > bye,
> > > with regards,
> > > Deepak.
> > > 
> > > --- Nanda Kishore MVS
> > > <nandakishoremvs@renaissance-it.com> wrote:
> > > 
> > > > Hi,
> > > > 	I think you will need the ant's lib folder
> > > > "${ANT_HOME}\lib" added to your classpath to
> run
> > > the
> > > > ant contrib tasks. And this lib folder needs
> to
> > be
> > > > in the classpath before your weblogic or other
> > > such
> > > > jars. Can you check that out?
> > > > 
> > > > Regards,
> > > > Nanda Kishore.
> > > > 
> > > > 
> > > > 
> > > > -----Original Message-----
> > > > From: Angeshwar Deepak
> > > [mailto:angeshwar@yahoo.com]
> > > > Sent: Monday, August 02, 2004 1:20 PM
> > > > To: user@ant.apache.org
> > > > Subject: <for> -Build Failed:problem
> > > > 
> > > > 
> > > > Hi,
> > > > 
> > > > I am using the <for> task under ant-contrib
> > task.
> > > > I am using Apache Ant version 1.6.2
> > > > I have placed ant-contrib-1.0b1.jar in the lib
> > > > folder
> > > > of Ant.
> > > > 
> > > > I have also added the following line
> > > > 
> > > > <taskdef
> > resource="net/sf/antcontrib/antlib.xml"/>
> > > > 
> > > > to the build file. I simply copied the <for>
> > task
> > > > from
> > > > the web.
> > > > The code is 
> > > > 
> > > > <taskdef
> > > >
> > >
> >
> resource="net/sf/antcontrib/antcontrib.properties"/>
> > > > 
> > > > <echo message="The first five letters of the
> > > > alphabet
> > > > are:"/>
> > > > <for list="a,b,c,d,e" param="letter">
> > > >   <sequential>
> > > >     <echo>Letter @{letter}</echo>
> > > >   </sequential>
> > > > </for>
> > > > 
> > > > But I get the error
> > > > 
> > > > Buildfile:
> > > >
> > >
> >
>
D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin\forrest.build.xml
> > > > 
> > > > init-props:
> > > > The first five letters of the alphabet are:
> > > > task
> CL=sun.misc.Launcher$AppClassLoader@e80a59
> > > > 
> > > > BUILD FAILED
> 
=== message truncated ===



		
__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message