ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angeshwar Deepak <angesh...@yahoo.com>
Subject RE: <for> -Build Failed:problem
Date Mon, 02 Aug 2004 09:42:14 GMT
Hi,

Do you mean to say this?-I have it I guess.

SET
CLASSPATH=D:\deepak\buildProcess_2\_tools\ant-1.6.2\lib\ant-contrib-0.6.jar;

and my complete set of classpath is

SET
PATH=c:\j2sdk1.4.2_04\bin;D:\deepak\buildProcess_2\_tools\ant-1.6.2\bin;D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin\bin
set JAVA_HOME=c:\j2sdk1.4.2_04
set ANT_HOME=D:\deepak\buildProcess_2\_tools\ant-1.6.2
set
PATH=%PATH%;%ANT_HOME%\bin;%PATH%;%FORREST_HOME%\bin 
set
FORREST_HOME=D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin
SET
CLASSPATH=D:\deepak\buildProcess_2\_tools\ant-1.6.2\lib\ant-contrib-0.6.jar;

bye,
with regards,
Deepak.

--- Nanda Kishore MVS
<nandakishoremvs@renaissance-it.com> wrote:

> Hi,
> 	I think you will need the ant's lib folder
> "${ANT_HOME}\lib" added to your classpath to run the
> ant contrib tasks. And this lib folder needs to be
> in the classpath before your weblogic or other such
> jars. Can you check that out?
> 
> Regards,
> Nanda Kishore.
> 
> 
> 
> -----Original Message-----
> From: Angeshwar Deepak [mailto:angeshwar@yahoo.com]
> Sent: Monday, August 02, 2004 1:20 PM
> To: user@ant.apache.org
> Subject: <for> -Build Failed:problem
> 
> 
> Hi,
> 
> I am using the <for> task under ant-contrib task.
> I am using Apache Ant version 1.6.2
> I have placed ant-contrib-1.0b1.jar in the lib
> folder
> of Ant.
> 
> I have also added the following line
> 
> <taskdef resource="net/sf/antcontrib/antlib.xml"/>
> 
> to the build file. I simply copied the <for> task
> from
> the web.
> The code is 
> 
> <taskdef
> resource="net/sf/antcontrib/antcontrib.properties"/>
> 
> <echo message="The first five letters of the
> alphabet
> are:"/>
> <for list="a,b,c,d,e" param="letter">
>   <sequential>
>     <echo>Letter @{letter}</echo>
>   </sequential>
> </for>
> 
> But I get the error
> 
> Buildfile:
>
D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin\forrest.build.xml
> 
> init-props:
> The first five letters of the alphabet are:
> task CL=sun.misc.Launcher$AppClassLoader@e80a59
> 
> BUILD FAILED
>
D:\deepak\buildProcess_2\_lib\build\apache-forrest-0.5.1-bin\forrest.build.xml:56:
> Could not create task of type: for du
> e to This task only works for ant >= 1.6Beta3
> 
> Total time: 1 second
> 
> I also checked the version of Ant I am using.
> 
> D:\deepak\buildProcess_2\logging>ant -version
> Apache Ant version 1.6.2 compiled on July 16 2004
> 
> Its the latest version. I have also set the
> classpath
> for ant-contrib-1.0b1.jar. Where could I be wrong
> and
> why do I get the error.
> Someone kindly help.
> 
> bye,
> with regards,
> Deepak.
> 
> 
> 		
> __________________________________
> Do you Yahoo!?
> New and Improved Yahoo! Mail - Send 10MB messages!
> http://promotions.yahoo.com/new_mail 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
> user-help@ant.apache.org
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> user-unsubscribe@ant.apache.org
> For additional commands, e-mail:
> user-help@ant.apache.org
> 
> 



		
__________________________________
Do you Yahoo!?
Y! Messenger - Communicate in real time. Download now. 
http://messenger.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message