ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kavita Tippanna <kavi...@andale.com>
Subject RE: HTML report problem with junitreport task.
Date Wed, 28 Jul 2004 04:43:10 GMT
OOPS!!!!  YES, u r right Maurice :-)
Such a simple mistake went unnoticed. THANKS A LOT :-) It does work now
exactly.

Thanks once again for pointing it out.

Regards,
Kavita.

-----Original Message-----
From: Maurice Feskanich [mailto:Maurice.Feskanich@Sun.COM]
Sent: Wednesday, July 28, 2004 1:09 AM
To: Ant Users List
Subject: Re: HTML report problem with junitreport task.


Something simple I noticed is that your fileset in the junitreport task
includes Test-*.xml, but the files that show up from junit are TEST-*.xml.
(Difference of case.)

Maury



Kavita Tippanna wrote:
> 
> Can anbody please look into this problem And guide me?? I'm lost in this
> problem :(
> 
> Thanks in advance.
> 
> -Kavita.
> 
> -----Original Message-----
> From: Kavita Tippanna
> Sent: Monday, July 19, 2004 1:15 PM
> To: 'Ant Users List'
> Cc: Sudindar Rao; Mysore Ravishankar
> Subject: RE: HTML report problem with junitreport task.
> 
> Hi,
> Thanks again for your valuable suggestions.
> 
> I tried showoutput="true" but without any success :( . Problem is all the
> same again.
> 
> -Kavita
> 
> -----Original Message-----
> From: Mani G. Iyer [mailto:iyer@rcn.com]
> Sent: Friday, July 16, 2004 7:12 PM
> To: 'Ant Users List'
> Subject: RE: HTML report problem with junitreport task.
> 
> Try using showoutput="true" in your junit task.  Let me know.  Thanks.
> 
> mani
> 
> -----Original Message-----
> From: Kavita Tippanna [mailto:kavitat@andale.com]
> Sent: Friday, July 16, 2004 8:31 AM
> To: 'Ant Users List'
> Subject: RE: HTML report problem with junitreport task.
> 
> Hi Mani,
> 
> First of all thanks for your quick response. :-)
> 
> Given below are the two file which i see in my reports directory.
> 1)TEST-test.vhub.lister.services.listerflows.OneStepListerFlowsTest.xml,
> 2)TESTS-TestSuites.xml
> 
> and in my reports/html dir i see the below file
> 1)junit-noframes.html
> 
> I have attached the files too if in case you find them usefull to get the
> root of the problem.
> 
> Thanks again..
> 
> -Kavita.
> 
> -----Original Message-----
> From: Mani G. Iyer [mailto:iyer@rcn.com]
> Sent: Friday, July 16, 2004 5:33 PM
> To: 'Ant Users List'
> Subject: RE: HTML report problem with junitreport task.
> 
> In your reports directory, what .xml files do you see?
> 
> Mani
> 
> -----Original Message-----
> From: Kavita Tippanna [mailto:kavitat@andale.com]
> Sent: Friday, July 16, 2004 6:04 AM
> To: 'user@ant.apache.org'
> Subject: HTML report problem with junitreport task.
> 
> Hi all,
> 
> We use ant1.6.1 & j2sdk1.4.2. I have a problem with generating html
reports
> with junitreport task.
> 
>  Problem goes like this,
> 
> "when I run my junit report task it runs fine without any errors but I do
> not see any entries found in html reports produced. "
> *It says tests '0'  Errors '0'  &  failures '0' & success rate 'Nan' where
> as I have some tests & are passing.
> *Test-testcasename.xml is generated with proper entries. junit.jar is
> included  in ANT_HOME/lib.
> * Other necessary jars I could find in the path ANT_HOME/lib as they come
> with ant 1.6.1.
> 
> My task is very simple which is as below..
> 
> <target name="report" depends="init" description="runs tests & generates
the
> html reports">
>    <junit  haltonfailure="false" printsummary="withOutAndErr">
>       <classpath refid="compile.classpath"/>
>       <formatter type="xml"/>
>       <test
> name="test.vhub.lister.services.listerflows.OneStepListerFlowsTest"
> todir="./reports"/>
>    </junit>
>    <junitreport todir="./reports">
>       <fileset dir="./reports" includes="Test-*.xml"/>
>       <report format="noframes" todir="./reports/html"/>
>    </junitreport>
> </target>
> 
> When i run the task with -verbose mode every thing looks fine. But when
run
> with -debug mode I could notice some "Could not load class" statements
which
> I'm pasting below with the junit/junitreport task outputs.
> 
>     [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 42.265 sec
>     [junit] Output:
>     [junit] Running
>
Test->test.vhub.lister.services.listerflows.OneStepListerFlowsTest.testOneSt
> epListerSaveFlow()
>     [junit] in Create New Id.........
>     [junit] Deleting Ad with ID : 741933
> 
> Could not load a dependent class
> (com/sun/media/jai/codec/FileSeekableStream) for type image
> Could not load a dependent class (com/jcraft/jsch/UserInfo) for type
sshexec
> Could not load a dependent class (com/jcraft/jsch/UserInfo) for type scp
> Could not load a dependent class (org/apache/commons/net/SocketClient) for
> type rexec
> Could not load class (org.apache.tools.ant.tasksdefs.cvslib.CvsVersion)
for
> type cvsversion
> Could not load a dependent class (com/starbase/starteam/Item) for type
> stlist
> Could not load a dependent class (org/apache/commons/net/SocketClient) for
> type telnet
> Could not load a dependent class (org/apache/commons/net/ftp/FTP) for type
> ftp
> Could not load a dependent class (jdepend/xmlui/JDepend) for type jdepend
> Could not load a dependent class (com/starbase/starteam/Item) for type
> stcheckin
> Could not load a dependent class (com/starbase/starteam/Item) for type
> stcheckout
> fileset: Setup scanner in dir C:\kavitat\home\tests\reports with
patternSet{
> includes: [Test-*.xml] excludes: [] }
> [junitreport] Using Xalan version: Xalan Java 2.4.1
> [junitreport] Transform time: 250ms
> 
>  am i missing something?? I tried working with lower versions ant too &
> ended with same problem. Please guide me as I'm new to ant.
> 
> Thanks in advance.
> 
> -Kavita.
> 
> ------------------------------------------
> Andale Information Technologies
> Kavita Tippanna
> Associate QA - White Box Engineer
> kavitat@andale.com <mailto:kavitat@andale.com>
> Andale Information Technologies
> II nd Block, 4th floor
> Prestige Blue Chip Software Park
> No 9, Hosur Road
> Bangalore
> tel: 080-51114012
> ------------------------------------------
> Want a signature like this? <http://www.plaxo.com/signature>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org

-- 
Maury Feskanich
 DReAM Support

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message