ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan.Mate...@rzf.fin-nrw.de
Subject AW: runant.pl issue
Date Tue, 20 Jul 2004 11:51:16 GMT
> I ran into an issue with the runant.pl script. If my 
> classpath contained
> spaces the ant code would not run.  It would interpret part 
> of the path as
> the target to execute in the ant script.
> 
> Here was the original line (line number 93 in runant.pl)
> my $classpath="$ENV{CLASSPATH}";
> I changed it to
> my $classpath="\"$ENV{CLASSPATH}\"";
> 
> This fixed my issue.  How should I submit this fix to the 
> list. Can someone
> point me to a document that describes the process?


http://ant.apache.org/problems.html

- ensure that the bug exists on CVS_HEAD
- create a diff
- open a bug report
- add the diff to that report


Mmh, but on CVS_HEAD the /src/script/runant.pl has something about Jikes.
Maybe you´re using an old version. Which version of Ant do you use?
Especially line 87 should contain:
    my $localpath = "$HOME/lib/ant-launcher.jar";

Jan



> 
> Mark Russell
> PNC
> 412-768-9603
> 
> 
> 
> -----------------------------------------
> The contents of this email are the property of PNC. If it was 
> not addressed to you, you have no legal right to read it. If 
> you think you received it in error, please notify the sender. 
> Do not forward or copy without permission of the sender.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message