ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Capper <geoffcap...@ozemail.com.au>
Subject Re: Java task - jar woes but classname goes - Thanks
Date Fri, 16 Jul 2004 12:56:08 GMT
Thanks Keith,

Turns out it was java I didn't understand then.

Kind regards and many thanks,

Geoff



Keith Hatton wrote:

>Hi Geoff,
>
>>>From the JDK Tool docs:
>
>java -jar ... "When you use this option, the JAR file is the source of all user classes,
and other user class path settings are ignored."
>
>If you want to launch an application using java -jar, then build that jar file with a
Class-Path entry in its manifest.
>
>Hope this helps
>Keith
>
>
>-----Original Message-----
>From: Geoff Capper [mailto:geoffcapper@ozemail.com.au]
>Sent: 16 July 2004 04:11
>To: Ant Users List
>Subject: Java task - jar woes but classname goes
>
>
>Hi,
>
>I'm not sure if I'm having a problem with my understanding of java or of 
>ant at this stage (or maybe just understanding in general), and I hope 
>that someone can point me in the right direction. My problem is as follows:
>
><snip>
>
>If I run "run-app" with a "classname" attribute, having included the 
>application jar in the classpath everything works fine.
>
>If I run "run-app" with a "jar" attribute for the application jar 
>(jarred using ant with a mainclass manifest element) I get a 
>NoClassDefFoundError for one of the Hibernate classes.
>
><snip>
>  
>



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message