ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Collin VanDyck <col...@hannonhill.com>
Subject Re: Problems using Ant CVS command
Date Fri, 09 Jul 2004 17:52:18 GMT
This worked great, thanks.

One thing is remaining -- I want to, though, be able to automate this so 
that all that has to be done is to run a script that logs in and then 
executes Ant via a .bat file.

I thought maybe I could execute an external shell command via ant to 
perform this login, but I can't seem to redirect standard in to enter 
the password automatically from a file.  In other words, I always have 
to be at the keyboard to enter the password.

If this is outside the scope of this list, that's ok I can look 
elsewhere, just hoping someone has been able to completely automate this 
process using Ant.

Thanks,
Collin


Andrew Craig wrote:

>Prior to running ant, run 'cvs login' on the command prompt from your
>sandbox directory, and enter your password.  This will store the
>password in wherever that version of CVS needs it.
>
>If you need to have the password that way, try using the version of
>cvs that comes with cygwin (http://www.cygwin.com) which does support
>reading the password file that way.
>
>Andrew
>
>
>On Fri, 09 Jul 2004 12:01:26 -0400, Collin VanDyck
><collin@hannonhill.com> wrote:
>  
>
>>Hello,
>>
>>I'm trying to use Ant (1.5.1) to automate grabbing latest source code
>>from our CVS (CVSNT) and I'm running into some problems authenticating.
>>Here's my test case that is supposed to 'ls' the latest from my JWebUnit
>>package:
>>
>>    <property name="cvsroot"
>>value=":pserver:Administrator@server:/cvsroot"/>
>>    <property name="cvscommand" value="ls"/>
>>    <property name="cvssource"    value="."/>
>>    <property name="cvspass"    value="cvspass"/>
>>    <property name="cvspackage" value="JWebUnit"/>
>>
>>    <target name="cvs">
>>        <cvspass cvsroot="${cvsroot}"
>>            password="password"
>>            passfile="${cvspass}"
>>        />
>>
>>        <cvs
>>            cvsroot="${cvsroot}"
>>            command="${cvscommand}"
>>            passfile="${cvspass}"
>>            package="${cvspackage}"
>>        />
>>
>>    </target>
>>
>>This is my target and how I'm trying to test connecting.  The result of
>>this target execution is:
>>
>>cvs:
>>      [cvs] Using cvs passfile: C:\Java\eclipse3\workspace\JWebUnit\cvspass
>>      [cvs] cvs ls: Empty password used - try 'cvs login' with a real
>>password
>>
>>      [cvs] cvs [ls aborted]: authorization failed: server server
>>rejected access to /cvsroot for user Administrator
>>
>>I'm guessing that my client cvs.exe does not support  reading from a
>>passfile. Indeed, I can't really find an option for specifying that when
>>I execute cvs --help-commands or cvs --help-options.
>>
>>I've tried the cvs.exe that comes with CVSNT, TortoiseCVS, and WinCVS,
>>and they all actually seem to be the same binary (they have the same
>>file size).  Is there a CVS that I could get for the windows platform
>>that would support the use of CVS with ant ?
>>
>>Or, am I missing something completely obvious?
>>
>>I searched the mailing lists archives and could not find a solution.
>>Someone mentioned that the WinCVS cvs.exe binary works for this case,
>>but I tried that with no success. :(
>>
>>thanks for any help!
>>Collin
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>>For additional commands, e-mail: user-help@ant.apache.org
>>
>>
>>    
>>
>
>
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message