ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Collin VanDyck <col...@hannonhill.com>
Subject Problems using Ant CVS command
Date Fri, 09 Jul 2004 16:01:26 GMT
Hello,

I'm trying to use Ant (1.5.1) to automate grabbing latest source code 
from our CVS (CVSNT) and I'm running into some problems authenticating.  
Here's my test case that is supposed to 'ls' the latest from my JWebUnit 
package:


    <property name="cvsroot"    
value=":pserver:Administrator@server:/cvsroot"/>
    <property name="cvscommand" value="ls"/>
    <property name="cvssource"    value="."/>
    <property name="cvspass"    value="cvspass"/>
    <property name="cvspackage" value="JWebUnit"/>
   
    <target name="cvs">
        <cvspass cvsroot="${cvsroot}"
            password="password"
            passfile="${cvspass}"
        />
       
        <cvs
            cvsroot="${cvsroot}"
            command="${cvscommand}"
            passfile="${cvspass}"
            package="${cvspackage}"
        />
       
    </target>


This is my target and how I'm trying to test connecting.  The result of 
this target execution is:

cvs:
      [cvs] Using cvs passfile: C:\Java\eclipse3\workspace\JWebUnit\cvspass
      [cvs] cvs ls: Empty password used - try 'cvs login' with a real 
password

      [cvs] cvs [ls aborted]: authorization failed: server server 
rejected access to /cvsroot for user Administrator


I'm guessing that my client cvs.exe does not support  reading from a 
passfile. Indeed, I can't really find an option for specifying that when 
I execute cvs --help-commands or cvs --help-options.

I've tried the cvs.exe that comes with CVSNT, TortoiseCVS, and WinCVS, 
and they all actually seem to be the same binary (they have the same 
file size).  Is there a CVS that I could get for the windows platform 
that would support the use of CVS with ant ?

Or, am I missing something completely obvious?

I searched the mailing lists archives and could not find a solution.  
Someone mentioned that the WinCVS cvs.exe binary works for this case, 
but I tried that with no success. :(

thanks for any help!
Collin





---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message