ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neta Bar Tal" <NE...@Amdocs.com>
Subject <depend> task
Date Tue, 08 Jun 2004 07:48:26 GMT

Hi All,
I have the following problem with <depend> task, I want to know if this
is done by design or do I miss anything.
I have the following structure of sources:

src1 -----test---com--util
src2 ----kuku--com--db


classes----test---com--util
           |__kuku--com--db

I have separate build.xml for every tree of sources because they belong
to separate building blocks.
I must have only one products area because those bb's are related to the
same application.
this is the depend task I'm using:

<depend cache="${env.CCWPA}/${env.CCBB}/depcache"
destdir="${env.CCWPA}/classes" srcdir="${env.CCWSCA}"
classpath="${classpath}"/>

when I run the build for src1 it builds ok all the products but when I
run the build for src2, classes from test are being deleted.
classes from kuku are depend on classes from src1, but as I understand
no classes that belong to the dependent classes should be deleted.

if class a depend on class b and class b is being built first . I don't
want the depend task to delete class b when I build class a.


did I miss something?
thanks in advance!

netaB




The information contained in this message is proprietary of Amdocs,
protected from disclosure, and may be privileged.
The information is intended to be conveyed only to the designated recipient(s)
of the message. If the reader of this message is not the intended recipient,
you are hereby notified that any dissemination, use, distribution or copying of
this communication is strictly prohibited and may be unlawful.
If you have received this communication in error, please notify us immediately
by replying to the message and deleting it from your computer.
Thank you.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message