ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reeves, Paul C" <>
Subject RE: Cannot Execute Solaris Unix "CC" Command With Ant Script
Date Fri, 25 Jun 2004 16:18:06 GMT

I have been able to use CC via ant on sun solaris, here is a code snippet
that worked for me.  Maybe the example will help you out.

            <!--Build the target-->
            <cc name="CC"
            outtype       ="shared"
            optimize      ="none"
            multithreaded = "false"
            objdir        ="${proj.build_dir}/build"
            runtime       ="dynamic"
            outfile       ="${proj.build_dir}/lib/pgl">
            <compilerarg value="-dalign -KPIC"/>
            <!--Set the source files -->
            <fileset dir="${proj.build_dir}/src">
              <include name="*.cc"/>
              <exclude name=""/>
              <exclude name=""/>
              <exclude name=""/>
              <exclude name=""/>
            <!--Paths for include files -->
            <includepath    location="${proj.build_dir}/include"/>
            <includepath    location="${proj.build_dir}/include/zlib"/>
            <!--Linker specifications -->
            <linker name = "CC">
              <linkerarg value="-L -Bdynamic -xlibmil -xlibmopt"
              <syslibset libs="Cstd,Crun,sunperf,fui,fsu,sunmath"

Good Luck,
-----Original Message-----
From: David F. White []
Sent: Friday, June 25, 2004 10:15 AM
Subject: Cannot Execute Solaris Unix "CC" Command With Ant Script

I have tried using the Ant task "<CC>" (available from as 
well as executing the "CC" command directly using the Ant core task 
"<exec>".  I am trying to build a C++ project on Solaris Unix.  When I 
execute the "CC" command directly from a command prompt everything works 
fine.  However, when the "CC" command is executed through an Ant script I 
receive the following error message:

License: Server (corona) not responding still trying
Cannot read data from license server
FLEX1m error:-16,287.  System Error: 22    Invalid argument

I receive the same error regardless as to which method I use (i.e. tasks 
<cc> or <exec>).  My guess is that this error is permissions or security 
related.  Has anyone else run into the same problem and resolved the issue?


Dave White

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message